Drop Box - Delayed Email Processing
Incident Report for Capsule
Resolved
The backlog of queued messages has now been fully processed and the time taken to store new messages using the Drop Box should now be back to normal.

Although these incidents are rare we are actively working on a solution to make the Drop Box more resilient.

Apologies for the disruption in your day.
Posted 7 days ago. Sep 09, 2019 - 10:53 UTC
Monitoring
Some users may be experiencing a delay in the storage of emails using our Drop Box feature. This was due to a server failure.

All messages sent to the Drop Box should have been queued for processing during this time but may take some time to appear in Capsule due to a backlog that has accumulated.

We are currently monitoring and will update once the backlog has been processed.
Posted 7 days ago. Sep 09, 2019 - 10:11 UTC
This incident affected: Drop Box.