Dropbox Processing Delay
Incident Report for Capsule
Resolved
This incident has been resolved.
Posted Oct 10, 2024 - 18:01 UTC
Monitoring
We have identified the cause of the delay and a mitigation has been put in place. We expect most delayed emails to be processed within 30 minutes.
Posted Oct 10, 2024 - 17:08 UTC
Investigating
We're currently experiencing delays storing emails sent to Capsule's dropbox addresses.

Our team is investigating and working on a fix.
Posted Oct 10, 2024 - 16:00 UTC
This incident affected: Drop Box.