Reports and Dashboards Delays

Incident Report for Capsule

Resolved

This issue is now fully resolved.
Posted Jul 08, 2026 - 13:12 UTC

Monitoring

A fix has been implemented and recent activity is available again in Reports and Dashboards. We're continuing to monitor application performance.
Posted Jul 06, 2026 - 15:33 UTC

Identified

An issue has been identified with Reports and Dashboards in Capsule. Activity from the last few days may not be displaying as expected.

This is due to a delay in processing the underlying data. All activity has been safely recorded and we're working to resolve this issue.

We will update this incident once we know more.
Posted Jul 06, 2026 - 10:35 UTC
This incident affected: Capsule.