BT Broadband Connectivity Issues
Incident Report for Capsule
Resolved
BT are reporting that the issue has been resolved. If affected please reboot your router and try connecting to Capsule again.
If you're still having issues please contact us.
Posted Oct 31, 2022 - 15:59 UTC
Identified
We're currently aware of an issue affecting some BT Broadband customer's access to Capsule. BT appear to be working on a fix.
Posted Oct 31, 2022 - 15:04 UTC